Sock Merchant - Hacker Rank Solution
Sock Merchant - Hacker Rank Solution
John works at a clothing store. He has a large pile of socks that he must pair by color for sale. Given an array of integers representing the color of each sock, determine how many pairs
of socks with matching colors there are.For example, there are socks with colors . There is one pair of color and one of color . There are three odd socks left, one of each color. The number of pairs is .
Function Description
Complete the sockMerchant function in the editor below. It must return an integer representing the number of matching pairs of socks that are available.
sockMerchant has the following parameter(s):
- n: the number of socks in the pile
- ar: the colors of each sock
Input Format
The first line contains an integer , the number of socks represented in .
The second line contains space-separated integers describing the colors of the socks in the pile.
The second line contains space-separated integers describing the colors of the socks in the pile.
Constraints
- where
Output Format
Return the total number of matching pairs of socks that John can sell.
Sample Input
9
10 20 20 10 10 30 50 10 20
Sample Output
3
Explanation
John can match three pairs of socks.
Sock Merchant - Hacker Rank Solution
To solve this challenge, we go through each color and count its frequency, . Once we've calculated all the frequencies, we calculate the number of pairs of each kind of sock as (using integer division). Finally, we print the total sum of all pairs of socks.
Problem Setter's code:
C++
#include <bits/stdc++.h>
using namespace std;
int main() {
int n;
cin>>n;
int freq[101] = {};
for(int i = 0; i < n; i++) {
int c;
cin >> c;
freq[c]++;
}
int res = 0;
for(int i = 0; i <= 100; i++){
res += freq[i] / 2;
}
cout << res << endl;
return 0;
}
Python 2.7
from itertools import groupby
n = int(raw_input())
c = map(int, raw_input().split())
ans = 0
for val in [len(list(group)) for key, group in groupby(sorted(c))]:
ans = ans + val/2
print ans
Problem Tester's code:Java
import java.util.*;
class Solution {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int n = scan.nextInt();
HashMap<Integer, Integer> colors = new HashMap<Integer, Integer>();
while(n-- > 0) {
int c = scan.nextInt();
Integer frequency = colors.get(c);
// If new color, add to map
if(frequency == null) {
colors.put(c, 1);
}
else { // Increment frequency of existing color
colors.put(c, frequency + 1);
}
}
scan.close();
// Count and print the number of pairs
int pairs = 0;
for(Integer frequency : colors.values()) {
pairs += frequency >> 1;
}
System.out.println(pairs);
}
}
0 Comments